Blog‎ > ‎

TT VME Graphics - Revisited

posted Jul 27, 2018, 2:51 AM by Joshua Kaijankoski
Just recently I posted the article TT VME Bus Fix - Does it really make it faster? where I compared performance before and after Atari's VME Bus Fix which all REV.H motherboards and up seem to have. As kind of expected, the gains were not significant. I mean we would have noticed this years ago. What is unexpected, however, is the sudden performance boost (on average) than just a few days ago. So what has changed? Am I missing something? If so, let me know.

Before I show the results, here's what has changed (I'll list everything even if it is seemingly unrelated):
  • Motherboard recapped
  • Rest of the rework done (My TT Gets Some Love)
  • New storage (TT Cable Management and Cooling - Extreme Edition)
  • New HDDriver version 10.12
  • Lightning USB installed and drivers loaded
  • New GAL and hardware mod to Nova as per Lightning installation.
  • Fresh NVDI 5.03 installation with Nova option. (SYS files disabled as before).
  • New English version of menu.prg

Not changed:
  • NVDI version
  • Gembench version
  • Nova drivers apart from menu.prg
  • Test OS TOS 3.06 Thunder&Lightning edition
Here is a comparison in 1280x1024x256 against exact same reference. The difference is staggering but not all are gains if you look closely.

And here is 1024x768x65536. Same story. Hard to believe that 16bit color at this resolution is almost as fast as TT-High.

So how much faster is Mach64 to the ET4000? I happen to have both. The reference is before all fixes so keep that in mind. Also that test was done without NVDI so to be fair I tested without it now as well. Resolution is at 1024x768x256. Pretty crazy.

Comments